[請問]未來phpBB 3.1一定要用PHP 5.3.2嗎? 謝謝

Webmasters Discussion
站長們到此分享架站甘苦、管理心得等;歡迎大家多多提出意見喔!
(請勿發表任何跟站長經驗分享不相干的文章,違者砍文)

版主: 版主管理群

主題已鎖定
yehrussell
竹貓忠實會員
竹貓忠實會員
文章: 564
註冊時間: 2006-01-03 07:48

[請問]未來phpBB 3.1一定要用PHP 5.3.2嗎? 謝謝

文章 yehrussell » 2012-09-06 00:49

[請問]未來phpBB 3.1一定要用PHP 5.3.2嗎? 謝謝
https://www.phpbb.com/community/viewtop ... &t=2152375
PHP 5.2以後就不支援phpBB 3.1 英文不太懂 :P
感恩
PS:不知本文章放此版合適否? 不合適請幫忙移文 :$ 謝謝
##### 以下為 '基本的發問格式' #####
●主機作業系統:租用主機
●快速架站程式: (請務必註明版本,如果安裝在自己電腦上才填寫)
●您的上網方式:
●您安裝的程式:Apache + php + MySql 或其他
PHP 版本: 5.6.40 + MySQL(i) 5.6.43
●您的 phpBB 版本: phpBB 3.2.7
●您的 domain (網域名稱) :herb-tw.com
●您的 phpBB 連結網址: https://herb-tw.com/phpBB/

阿維
竹貓忠實會員
竹貓忠實會員
文章: 911
註冊時間: 2003-02-23 13:36
來自: 台南市

Re: [請問]未來phpBB 3.1一定要用PHP 5.3.2嗎? 謝謝

文章 阿維 » 2012-09-06 02:01

應該是這樣沒錯了!
就好比說在 php4 上面安裝 phpBB3 就算程式本身是最新版本,駭客還是會因為 php4 本身的漏洞,針對特定目錄放木馬檔案或直接對主機攻擊。(這是我的實際經驗)
提供代客維護 phpBB 3.0.x 以及外掛/風格升級或安裝的服務,如需委託,請與我聯絡,謝謝! ;)
我的 Skype 帳號:gpxjordan

richer
星球公民
星球公民
文章: 175
註冊時間: 2004-09-14 12:55
來自: 幻想的世界
聯繫:

Re: [請問]未來phpBB 3.1一定要用PHP 5.3.2嗎? 謝謝

文章 richer » 2012-09-06 16:42

重點不是在於駭客會不會入侵,雖然這事情也很重要。

目前的程式已經有使用到一些 php 5.3.2 以後的版本才有的函式。
現階段為了讓更多人可以使用,同時也給使用者時間升級系統。
所以對於那些 5.3.2 以前版本不支援的函式,官方以其他 php 函式自己撰寫出來使用。

將來 3.1 版本皆移除這些函式,因此當你使用 php 5.3.2 以前的版本,論壇是無法完全的順利運作的。
另外一方面,php 官方也已經宣告了 php 5.2 系列的死刑了(停止維護)。
DC club 對分散式運算的小小貢獻
Matiz Club
●空間商: ACSite.NET
●服務程式:Linux + LiteSpeed V5.4 + php 5.2.14 + MySQL(i) 5.0.85 + phpBB 3.0.11

阿維
竹貓忠實會員
竹貓忠實會員
文章: 911
註冊時間: 2003-02-23 13:36
來自: 台南市

Re: [請問]未來phpBB 3.1一定要用PHP 5.3.2嗎? 謝謝

文章 阿維 » 2012-09-06 17:18

就當作我們是綜合答案吧…
因為我有在幫幾家主機商處理有關 php 問題的,所以我們比較注重於安全性因素。
當然也發現新的程式對於安裝門檻也越來越高了,不論是 php 版本或相關主機套件。
回歸正傳,如果沒有將 php 升級到較新的版本,說真的還蠻危險的,因為我就常發現某個目錄被灌爆一堆木馬檔案。
我們只能多拉一個算一個啦!如果客戶不願意轉換主機,那我們也沒辦法,這就是目前各主機商的現況!
提供代客維護 phpBB 3.0.x 以及外掛/風格升級或安裝的服務,如需委託,請與我聯絡,謝謝! ;)
我的 Skype 帳號:gpxjordan

頭像
心靈捕手
默默耕耘的老師
默默耕耘的老師
文章: 8621
註冊時間: 2004-04-30 01:54
來自: Taiwan

Re: [請問]未來phpBB 3.1一定要用PHP 5.3.2嗎? 謝謝

文章 心靈捕手 » 2012-09-06 22:28

yehrussell 寫:[請問]未來phpBB 3.1一定要用PHP 5.3.2嗎? 謝謝
https://www.phpbb.com/community/viewtop ... &t=2152375
PHP 5.2以後就不支援phpBB 3.1 英文不太懂 :P
感恩
PS:不知本文章放此版合適否? 不合適請幫忙移文 :$ 謝謝
官方公告的主旨是下一個 phpBB 3.1(Ascraeus)版本將需要 PHP 5.3.2 或更新的版本。

也就是說,到那個時候,如果您的 PHP 版本尚未更新到 5.3.2 版以上,那麼將無法順利安裝 phpBB 3.1 版。 :-)

p.s.
移動到「站長交流」版面。
施比受有福,歡迎來信賜教,謝謝 & 再見!
祝福您 好運 ^_^
歡迎加入★★心靈捕手★★ :: 討論區!!
http://wang5555.hopto.org/phpBB3/
p.s. 奉老婆之命:在晚上十一點前,得關機睡覺!!!

tonylee5566
星球公民
星球公民
文章: 34
註冊時間: 2012-05-27 17:26
聯繫:

Re: [請問]未來phpBB 3.1一定要用PHP 5.3.2嗎? 謝謝

文章 tonylee5566 » 2012-09-07 23:28

記錄下, 我還沒有更新... 未來我倒想用 nginx ... 聽說會很快 ..

頭像
心靈捕手
默默耕耘的老師
默默耕耘的老師
文章: 8621
註冊時間: 2004-04-30 01:54
來自: Taiwan

未來的 phpBB 3.1 需要用 PHP 5.3.3 或更新的版本

文章 心靈捕手 » 2012-11-17 10:14

官方的公告(更新):
未來的 phpBB 3.1 需要用 PHP 5.3.3 或更新的版本。

參考連結:
https://www.phpbb.com/community/viewtop ... #p13198246
施比受有福,歡迎來信賜教,謝謝 & 再見!
祝福您 好運 ^_^
歡迎加入★★心靈捕手★★ :: 討論區!!
http://wang5555.hopto.org/phpBB3/
p.s. 奉老婆之命:在晚上十一點前,得關機睡覺!!!

yehrussell
竹貓忠實會員
竹貓忠實會員
文章: 564
註冊時間: 2006-01-03 07:48

Re: 未來的 phpBB 3.1 需要用 PHP 5.3.3 或更新的版本

文章 yehrussell » 2012-11-17 10:28

心靈捕手 寫:官方的公告(更新):
未來的 phpBB 3.1 需要用 PHP 5.3.3 或更新的版本。

參考連結:
https://www.phpbb.com/community/viewtop ... #p13198246
謝謝捕手老師 (:Y) 非常用心的資訊 (:l)
##### 以下為 '基本的發問格式' #####
●主機作業系統:租用主機
●快速架站程式: (請務必註明版本,如果安裝在自己電腦上才填寫)
●您的上網方式:
●您安裝的程式:Apache + php + MySql 或其他
PHP 版本: 5.6.40 + MySQL(i) 5.6.43
●您的 phpBB 版本: phpBB 3.2.7
●您的 domain (網域名稱) :herb-tw.com
●您的 phpBB 連結網址: https://herb-tw.com/phpBB/

主題已鎖定

回到「站長交流」