[討論]PHPBB2.0.5升級2.0.8(以解決)

與 phpBB 2.0.x 相關主題。

版主: 版主管理群

回覆文章
神川小羽
調皮の小羽
調皮の小羽
文章: 1464
註冊時間: 2004-05-01 05:55
來自: 謎樣之筱語
聯繫:

[討論]PHPBB2.0.5升級2.0.8(以解決)

文章 神川小羽 » 2004-05-28 00:56

●架設主機作業系統:Windows(98 2000雙作業系統)架站用2000
●我的上網方式:ADSL HINET2.0/384浮動IP
●我安裝的程式:Apache HTTP Server 2.0.47 + PHP Version 4.3.2 + MySql4.0.12
●我的 phpBB2 版本:phpBB 2.0.5
●我的 domain(網域名稱) :www.adsldns.org
●我的 phpBB2 連結網址http://0928.adsldns.org/

狀況如下
我的PHPBB目前是2.0.5我想要升級到2.0.8是否可以用以下的方式來直接取代捏,(偶知道這不是正確的做法只是想嘗試看看)。
首先把我的PHPBB資料夾壓縮備份預防萬一,再把PHPBB資料夾刪除,在把2.0.8.ZIP解壓縮在我的根目錄後直接把這個全新的PHPBB資料夾下的
contrib跟install這兩個資料夾砍掉。
我剛剛有測試過感覺起來好像沒啥密問題,除了發現我裝的外掛沒了(廢話) :lol:
還有就是網頁最下面的版權宣告還是保持2.0.5的字樣\r
Powered by phpBB 2.0.5 © 2001, 2002 phpBB Group
正體中文語系由 phpbb-tw 維護製作
以下是我在2.0.5裝過的外掛(修改)紀錄列表
水怪RPG
CashMod221
attach_mod_v239
快速砍人\r
推薦網站簡易版
快速回覆
左上角LOGO改為SWF
水怪XX刑場留言版
加速論壇(關閉除錯模式)
問題如下
Q1:要如何把2.0.5的字改成2.0.8
Q2.如我要把原本我2.0.5的外掛裝到新的2.0.8有動到資料庫的部分是否就不用在敲入SQL語法而只要編輯.PHP那些檔案即可?
Q3.如果我用這樣的方式來升級會不會有衍生出問題?

以上的蠢問題還勞架竹貓諸位高手指導,感謝感謝。
最後由 神川小羽 於 2004-06-29 13:53 編輯,總共編輯了 2 次。
-.-

依夢兒
竹貓忠實會員
竹貓忠實會員
文章: 2013
註冊時間: 2002-11-20 00:07

文章 依夢兒 » 2004-05-28 01:08

印象中 2.0.5 至 2.0.8 的變化不大,由於你已經安裝很多外掛了,所以建議你用手動的方式慢慢更新。
也就是 2.0.5 > 2.0.6 > 2.0.7 > 2.0.7a > 2.0.8 > 2.0.8a 。

2.0.5 > 2.0.6:http://phpbb-tw.net/phpbb/viewtopic.php?t=18439
2.0.6 > 2.0.7:http://phpbb-tw.net/phpbb/viewtopic.php?t=24194
2.0.7 > 2.0.7a:http://www.phpbb.com/phpBB/viewtopic.php?t=182281
2.0.7a > 2.0.8:http://www.phpbb.com/phpBB/viewtopic.php?t=183982
2.0.8 > 2.0.8a:http://www.phpbb.com/phpBB/viewtopic.php?t=185180

資料庫的部份,應該沒有更動,只要將 phpbb_config 內的 version 由 .0.5 改成 .0.8 就可以了。
有任何關於 phpBB 或是架站的問題,請在論壇上公開發表出來,大家一起討論。
請不要丟私人訊息問我,因為私訊是用來聊私事的。
這樣作對於解決您的問題一點幫助也沒有,也很沒有效率,小弟我一概謝絕。



搜尋是一種美德,在發問之前,請多加利用頂端的文章搜尋功能,搜尋可能的關鍵字。
確定您想問的問題找不到答案後,再發問。

神川小羽
調皮の小羽
調皮の小羽
文章: 1464
註冊時間: 2004-05-01 05:55
來自: 謎樣之筱語
聯繫:

文章 神川小羽 » 2004-05-28 02:57

首先感謝依夢兒大大的解說,還特地整理出這些版本更新的連結點偶好感動。
再來是依夢兒大大說到\r
資料庫的部份,應該沒有更動
那也就是說其實直接套用2.0.8也是沒關係只是如果我用現在的2.0.5逐步的更新來保存我安裝過的外掛,是這樣的嗎?
因為其實我是本來就打算把部分外掛拿掉,好比水怪問題不少,甚至我的有些會員還會因為水怪的BUG跟其他會員有文字上的衝突(會員砍會員....)光是這個偶就頭痛好幾天嚕所以還想要拆掉說,還有我發現外掛裝多了真的會變慢說,因為偶只是練習階段所以架在自機上用破破的ADSL還是要計較流量問題好點。
再來是夢大說到的
phpbb_config 內的 version 由 .0.5 改成 .0.8 就可以了。
其實我原本以為這個修改是在language目錄下偶找了好久每個檔案都翻了好幾遍就是找不到說原來是在資料庫裡面!!讓大家見笑了^^"

============================================

上次有人問到關於修改版本顯示問題 因為這裡是教學文件庫 沒辦法回覆文章只好在這篇在整理以下
關於使用phpMyAdmin修改版本顯示\r
首先 進入phpMyAdmin 選擇你的資料庫 找到資料表 phpbb_config 在這個的右邊有一個小圖示 游標比上去會出現(瀏覽)就是這個點下去 注意到頁碼一頁一頁翻下去 一定可以找到version這個欄位
請看下圖
  • 選擇你使用的資料庫\r
    圖檔
    留意下圖的2個紅色圈圈 左邊的就是指phpbb_config資料表右邊的是編輯(請點小圖示)
    圖檔
    這個就是version欄位了 點下小鉛筆去修改數值即可嚕
    圖檔
最後由 神川小羽 於 2004-06-29 13:51 編輯,總共編輯了 2 次。
-.-

依夢兒
竹貓忠實會員
竹貓忠實會員
文章: 2013
註冊時間: 2002-11-20 00:07

文章 依夢兒 » 2004-05-28 03:49

神川小羽 寫:那也就是說其實直接套用2.0.8也是沒關係只是如果我用現在的2.0.5逐步的更新來保存我安裝過的外掛,是這樣的嗎?
是的。

如果說,你不要外掛,想要重新安裝一個 2.0.8 ,然後延用資料庫的舊資料,也是可以的。
有任何關於 phpBB 或是架站的問題,請在論壇上公開發表出來,大家一起討論。
請不要丟私人訊息問我,因為私訊是用來聊私事的。
這樣作對於解決您的問題一點幫助也沒有,也很沒有效率,小弟我一概謝絕。



搜尋是一種美德,在發問之前,請多加利用頂端的文章搜尋功能,搜尋可能的關鍵字。
確定您想問的問題找不到答案後,再發問。

回覆文章

回到「2.0」